CVE-2022-23502 is a medium-severity (CVSS 5.4) CWE-613 vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
TYPO3 contains Insufficient Session Expiration after Password Reset
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-23502.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TYPO3 is an open source PHP based web content management system. In versions prior to 10.4.33, 11.5.20, and 12.1.1, When users reset their password using the corresponding password recovery functionality, existing sessions for that particular user account were not revoked. This applied to both frontend user sessions and backend user sessions. This issue is patched in versions 10.4.33, 11.5.20, 12.1.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 10.0.0&&< 10.4.33 | 10.4.33composer require typo3/cms-core:^10.4.33 |
| 🐘Packagist | typo3/cms-core | ≥ 11.0.0&&< 11.5.20 | 11.5.20composer require typo3/cms-core:^11.5.20 |
| 🐘Packagist | typo3/cms-core | ≥ 12.0.0&&< 12.1.1 | 12.1.1composer require typo3/cms-core:^12.1.1 |
| 🐘Packagist | typo3/cms | ≥ 10.0.0&&< 10.4.33 | 10.4.33composer require typo3/cms:^10.4.33 |
| 🐘Packagist | typo3/cms | ≥ 11.0.0&&< 11.5.20 | 11.5.20composer require typo3/cms:^11.5.20 |
| 🐘Packagist | typo3/cms | ≥ 12.0.0&&< 12.1.1 | 12.1.1composer require typo3/cms:^12.1.1 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 10.4.33 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23502 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-23502 in your dependencies?
Find it across Packagist, including transitive dependencies.