NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-23500 — cms-core

MEDIUMFix: TYPO3/typo3@1e5f444

CVE-2022-23500 is a medium-severity (CVSS 5.9) CWE-674 vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

TYPO3 subject to Uncontrolled Recursion resulting in Denial of Service

Also known asBIT-typo3-2022-23500GHSA-8c28-5mp7-v24h
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-23500.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.3%0.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20 or 12.1.1.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 9.0.0&&< 9.5.389.5.38composer require typo3/cms-core:^9.5.38
🐘Packagisttypo3/cms-core≥ 10.0.0&&< 10.4.3310.4.33composer require typo3/cms-core:^10.4.33
🐘Packagisttypo3/cms-core≥ 11.0.0&&< 11.5.2011.5.20composer require typo3/cms-core:^11.5.20
🐘Packagisttypo3/cms≥ 10.0.0&&< 10.4.3310.4.33composer require typo3/cms:^10.4.33
🐘Packagisttypo3/cms≥ 11.0.0&&< 11.5.2011.5.20composer require typo3/cms:^11.5.20

Affected Products

1 product · 3 configurations
Application
typo3typo3
≥ 11.0.0 && < 11.5.20
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 9.5.38 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23500 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions
O3 Security · Impact-Aware SCA

Is CVE-2022-23500 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-23500: cms-core — Fixed in 9.5.38