CVE-2022-23485 is a medium-severity (CVSS 6.4) Improper Privilege Management vulnerability in sentry. A fix is available for sentry — see the affected versions and patch details below.
Invite code reuse via cookie manipulation in sentry
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-23485.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sentryReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
With a known valid invite link (i.e. not already accepted or expired) an unauthenticated attacker can manipulate the cookie to allow the same invite link to be reused on multiple accounts when joining an organization.
Impact
An attacker with a valid invite link can create multiple users and join the organization from which the invite link was generated.
Patches
This issue was patched in version 22.11.0.
Workarounds
Sentry SaaS customers do not need to take action.
Self-hosted Sentry installs can disable the invite functionality until they are ready to deploy the patched version by editing their sentry.conf.py file (usually located at ~/.sentry/).
-
Add the following line into
sentry.conf.py:SENTRY_FEATURES["organizations:invite-members"] = False -
Restart the Sentry web service.
docker compose restart web
For more information
If you have any questions or comments about this advisory:
- Visit our FAQs on this CVE
- Open an issue in getsentry/sentry
- Email us at security[@]sentry.io
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | sentry | ≥ 20.6.0&&< 22.11.0 | 22.11.0pip install --upgrade 'sentry==22.11.0' |
Affected Products
sentrysentryDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sentry, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sentry to 22.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23485 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2022-23485 in your dependencies?
Find it across PyPI, including transitive dependencies.