CVE-2022-23451 is a high-severity (CVSS 8.1) CWE-863 vulnerability in barbican. A fix is available for barbican — see the affected versions and patch details below.
Barbican authorization flaw before v14.0.0
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
barbicanReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An authorization flaw was found in openstack-barbican. The default policy rules for the secret metadata API allowed any authenticated user to add, modify, or delete metadata from any secret regardless of ownership. This flaw allows an attacker on the network to modify or delete protected data, causing a denial of service by consuming protected resources.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | barbican | all versions | 14.0.0pip install --upgrade 'barbican==14.0.0' |
Affected Products
barbicanopenstackopenstack platformredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for barbican, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update barbican to 14.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23451 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 16.1 | openstack-barbican-0:9.0.1-1.20220916133702.07be198.el8ost | RHSA-2022:8874 |
| Red Hat OpenStack Platform 16.2 | openstack-barbican-0:9.0.2-2.20220122185348.c718783.el8ost | RHSA-2022:5114 |
Frequently Asked Questions
Is CVE-2022-23451 in your dependencies?
Find it across PyPI, including transitive dependencies.