CVE-2022-23066 is a critical-severity (CVSS 9.1) CWE-682 vulnerability in solana_rbpf. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for solana_rbpf — see the affected versions and patch details below.
Solana rBPF - Incorrect Calculation in sdiv instruction
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
solana_rbpfReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
In Solana rBPF versions 0.2.26 and 0.2.27 are affected by Incorrect Calculation which is caused by improper implementation of sdiv instruction. This can lead to the wrong execution path, resulting in huge loss in specific cases. For example, the result of a sdiv instruction may decide whether to transfer tokens or not. The vulnerability affects both integrity and may cause serious availability problems.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | solana_rbpf | ≥ 0.2.26&&< 0.2.28 | 0.2.28cargo update -p solana_rbpf --precise 0.2.28 |
Affected Products
rbpfsolanaResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for solana_rbpf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update solana_rbpf to 0.2.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23066 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-23066 in your dependencies?
Find it across crates.io, including transitive dependencies.