NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-22971 — spring-messaging

MEDIUMFix: spring-projects/spring-framework@159a99b

CVE-2022-22971 is a medium-severity (CVSS 6.5) CWE-770 vulnerability in org.springframework:spring-messaging. A fix is available for org.springframework:spring-messaging — see the affected versions and patch details below.

Allocation of Resources Without Limits or Throttling in Spring Framework

Also known asGHSA-rqph-vqwm-22vc
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.35%2.70%4.05%0.3%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.springframework:spring-messaging☕org.springframework:spring-messaging

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vulnerable to a denial of service attack by an authenticated user.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework:spring-messaging≥ 5.3.0&&< 5.3.205.3.20org.springframework:spring-messaging:5.3.20
☕Mavenorg.springframework:spring-messagingall versions5.2.22.RELEASEorg.springframework:spring-messaging:5.2.22.RELEASE

Affected Products

4 products · 6 configurations
Application
cloud secure agentnetapp
all
Application
oncommand insightnetapp
all
Application
financial services crime and compliance management studiooracle
2 versions
8.0.8.2.08.0.8.3.0
Application
spring frameworkvmware
≥ 5.3.0 && ≤ 5.3.19
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-messaging, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework:spring-messaging to 5.3.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-22971 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
AMQ Broker 7.10.3springframeworkRHSA-2023:3185
AMQ Broker 7.11.0see advisoryRHSA-2023:1661
Red Hat Fuse 7.11springframeworkRHSA-2022:5532

Frequently Asked Questions

In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vulnerable to a denial of service attack by an authenticated user.
O3 Security · Impact-Aware SCA

Is CVE-2022-22971 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-22971: spring-messaging DoS — Fixed in 5.3.20