CVE-2022-22968 is a high-severity (CVSS 7.5) CWE-178 vulnerability in org.springframework:spring-context. A fix is available for org.springframework:spring-context — see the affected versions and patch details below.
Improper handling of case sensitivity in Spring Framework
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-22968.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.springframework:spring-context☕org.springframework:spring-contextReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Spring Framework versions 5.3.0 - 5.3.18, 5.2.0 - 5.2.20, and older unsupported versions, the patterns for disallowedFields on a DataBinder are case sensitive which means a field is not effectively protected unless it is listed with both upper and lower case for the first character of the field, including upper and lower case for the first character of all nested fields within the property path. Versions 5.3.19 and 5.2.21 contain a patch for this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework:spring-context | ≥ 5.3.0&&< 5.3.19 | 5.3.19org.springframework:spring-context:5.3.19 |
| ☕Maven | org.springframework:spring-context | all versions | 5.2.21.RELEASEorg.springframework:spring-context:5.2.21.RELEASE |
Affected Products
active iq unified managernetappcloud secure agentnetappmetrocluster tiebreakernetappsnap creator frameworknetappsnapmanagernetappmysql enterprise monitororacleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-context, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework:spring-context to 5.3.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-22968 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ 7.10.0 | springframework | RHSA-2022:5101 |
| Red Hat Fuse 7.11 | springframework | RHSA-2022:5532 |
Frequently Asked Questions
Is CVE-2022-22968 in your dependencies?
Find it across Maven, including transitive dependencies.