NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2022-21986 — Microsoft.AspNetCore.App.…

HIGH

CVE-2022-21986 is a high-severity (CVSS 7.5) vulnerability in Microsoft.AspNetCore.App.Runtime.win-x64. A fix is available for Microsoft.AspNetCore.App.Runtime.win-x64 — see the affected versions and patch details below.

.NET Denial of Service Vulnerability

Also known asBIT-dotnet-2022-21986BIT-dotnet-sdk-2022-21986GHSA-x459-p2rx-f8ff
Published
Updated
Affected
23 pkgs
Patched
23 / 23
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-21986.

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
1.09%2.18%3.26%4.35%1.7%3.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

23 pkgs affected
.NETMicrosoft.AspNetCore.App.Runtime.win-x64.NETMicrosoft.AspNetCore.App.Runtime.linux-x64.NETMicrosoft.AspNetCore.App.Runtime.win-x86.NETMicrosoft.AspNetCore.App.Runtime.osx-x64.NETMicrosoft.AspNetCore.App.Runtime.linux-musl-x64.NETMicrosoft.AspNetCore.App.Runtime.linux-arm64.NETMicrosoft.AspNetCore.App.Runtime.linux-arm.NETMicrosoft.AspNetCore.App.Runtime.win-arm64+15 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0 and .NET 5.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.

A Denial of Service vulnerability exists in .NET 6.0 and .NET 5.0 when the Kestrel web server processes certain HTTP/2 and HTTP/3 requests.

Affected Software

  • Any .NET 6.0 application running on .NET 6.0.1 or lower.
  • Any .NET 5.0 application running on .NET 5.0.13 or lower.

Patches

To fix the issue, please install the latest version of .NET 6.0 or .NET 5.0. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.

.NET 6.0 and .NET 5.0 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.

Other Details

Affected Packages

23 total 23 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.AspNetCore.App.Runtime.win-x64≥ 5.0.0&&< 5.0.145.0.14dotnet add package Microsoft.AspNetCore.App.Runtime.win-x64 --version 5.0.14
.NETNuGetMicrosoft.AspNetCore.App.Runtime.linux-x64≥ 5.0.0&&< 5.0.145.0.14dotnet add package Microsoft.AspNetCore.App.Runtime.linux-x64 --version 5.0.14
.NETNuGetMicrosoft.AspNetCore.App.Runtime.win-x86≥ 5.0.0&&< 5.0.145.0.14dotnet add package Microsoft.AspNetCore.App.Runtime.win-x86 --version 5.0.14
.NETNuGetMicrosoft.AspNetCore.App.Runtime.osx-x64≥ 5.0.0&&< 5.0.145.0.14dotnet add package Microsoft.AspNetCore.App.Runtime.osx-x64 --version 5.0.14
.NETNuGetMicrosoft.AspNetCore.App.Runtime.linux-musl-x64≥ 5.0.0&&< 5.0.145.0.14dotnet add package Microsoft.AspNetCore.App.Runtime.linux-musl-x64 --version 5.0.14
.NETNuGetMicrosoft.AspNetCore.App.Runtime.linux-arm64≥ 5.0.0&&< 5.0.145.0.14dotnet add package Microsoft.AspNetCore.App.Runtime.linux-arm64 --version 5.0.14

Affected Products

4 products · 7 configurations
OS
fedorafedoraproject
2 versions
3435
Application
.netmicrosoft
≥ 6.0.0 && < 6.0.2
range
Application
visual studio 2019microsoft
≥ 16.0 && ≤ 16.11
range
Application
visual studio 2022microsoft
≥ 17.0 && < 17.0.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.App.Runtime.win-x64, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.AspNetCore.App.Runtime.win-x64 to 5.0.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21986 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
.NET Core on Red Hat Enterprise Linuxrh-dotnet50-dotnet-0:5.0.211-1.el7_9RHSA-2022:0499
.NET Core on Red Hat Enterprise Linuxrh-dotnet60-dotnet-0:6.0.102-1.el7_9RHSA-2022:0500
Red Hat Enterprise Linux 8dotnet5.0-0:5.0.211-1.el8_5RHSA-2022:0495
Red Hat Enterprise Linux 8dotnet6.0-0:6.0.102-1.el8_5RHSA-2022:0496

Frequently Asked Questions

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0 and .NET 5.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A Denial of Service vulnerability exists in .NET 6.0 and .NET 5.0 when the Kestrel web server processes certain HTTP/2 and HTTP/3 requests. ### Affected Software * Any .NET 6.0 application running on .NET 6.0.1 or lower. * Any .NET 5.0 application running on .NET 5.0.13 or lower. ### Patches To fix the issue, please install the latest version of .NET 6.0
O3 Security · Impact-Aware SCA

Is CVE-2022-21986 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2022-21986: DoS — Fixed in 5.0.14