CVE-2022-21822 — nvflare
HIGHCVE-2022-21822 is a high-severity (CVSS 7.5) CWE-770 vulnerability in nvflare. A fix is available for nvflare — see the affected versions and patch details below.
Allocation of Resources Without Limits or Throttling in nvflare
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nvflareReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
NVIDIA FLARE contains a vulnerability in Admin Interface, where an un-authorized attacker can cause Allocation of Resources Without Limits or Throttling, which may lead to cause system unavailable
All versions before 2.0.16 are affected.
Patches
The patch will be included in nvflare==2.0.16.
Workarounds
The changes in commits https://github.com/NVIDIA/NVFlare/commit/93588b3a0dff9bd4568983071b74d8b420de3a6e and https://github.com/NVIDIA/NVFlare/commit/93588b3a0dff9bd4568983071b74d8b420de3a6e can be applied to any version of the NVIDIA FLARE without any adverse effect.
Additional information
Issue Found on: 2022.3.3 Issue Found by: Oliver Sellwood (@Nintorac)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nvflare | all versions | 2.0.16pip install --upgrade 'nvflare==2.0.16' |
Affected Products
federated learning application runtime environmentnvidiaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nvflare, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nvflare to 2.0.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21822 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-21822 in your dependencies?
Find it across PyPI, including transitive dependencies.