CVE-2022-21718 is a low-severity (CVSS 3.4) CWE-668 vulnerability in electron. A fix is available for electron — see the affected versions and patch details below.
Renderers can obtain access to random bluetooth device without permission in Electron
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
electronnpmDescription
Impact
This vulnerability allows renderers to obtain access to a random bluetooth device via the web bluetooth API if the app has not configured a custom select-bluetooth-device event handler. The device that is accessed is random and the attacker would have no way of selecting a specific device.
All current stable versions of Electron are affected.
Patches
This has been patched and the following Electron versions contain the fix:
17.0.0-alpha.616.0.615.3.514.2.413.6.6
Workarounds
Adding this code to your app can workaround the issue.
app.on('web-contents-created', (event, webContents) => {
webContents.on('select-bluetooth-device', (event, devices, callback) => {
// Prevent default behavior
event.preventDefault();
// Cancel the request
callback('');
});
});
For more information If you have any questions or comments about this advisory, email us at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | electron | all versions | 13.6.6npm install electron@13.6.6 |
| 📦npm | electron | ≥ 14.0.0-beta.1&&< 14.2.4 | 14.2.4npm install electron@14.2.4 |
| 📦npm | electron | ≥ 15.0.0-beta.1&&< 15.3.5 | 15.3.5npm install electron@15.3.5 |
| 📦npm | electron | ≥ 16.0.0-beta.1&&< 16.0.6 | 16.0.6npm install electron@16.0.6 |
| 📦npm | electron | ≥ 17.0.0-alpha.1&&< 17.0.0-alpha.6 | 17.0.0-alpha.6npm install electron@17.0.0-alpha.6 |
Affected Products
electronelectronjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update electron to 13.6.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21718 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-21718 in your dependencies?
Find it across npm, including transitive dependencies.