NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-2130 — microweber

MEDIUMFix: microweber/microweber@dbd37dd

CVE-2022-2130 is a medium-severity (CVSS 6.5) Cross-site Scripting (XSS) vulnerability in microweber/microweber. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

Cross-site Scripting (XSS) - Reflected in microweber/microweber

Also known asGHSA-27g3-58v4-fg9w
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%19.9%39.8%59.7%46.6%3.1%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘microweber/microweber

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Microweber versions 1.2.17 and prior are vulnerable to cross-site scripting. A patch is available on the dev laravel9-php8 branch of the repository.

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
🐘Packagistmicroweber/microweberall versionsNo fix

Affected Products

1 product · 1 configurations
Application
microwebermicroweber
< 1.2.17
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for microweber/microweber, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of microweber/microweber for CVE-2022-2130. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2022-2130

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2022-2130 -u https://target
Template
Microweber < 1.2.17 - Cross-Site Scripting
Severity
medium
Impact
Successful exploitation could allow an attacker to execute malicious scripts in the context of a victim's browser, leading to potential data theft or account compromise.
Remediation
Upgrade Microweber CMS to version 1.2.17 or later to mitigate the Reflected XSS vulnerability (CVE-2022-2130).

Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Microweber versions 1.2.17 and prior are vulnerable to cross-site scripting. A patch is available on the `dev laravel9-php8` branch of the repository.
O3 Security · Impact-Aware SCA

Is CVE-2022-2130 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-2130: microweber XSS (Medium 6.5)