NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-21222 — css-what

MEDIUMFix: fb55/css-what@dc51092

CVE-2022-21222 is a medium-severity (CVSS 5.3) CWE-1333 vulnerability in css-what. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for css-what — see the affected versions and patch details below.

Regular Expression Denial of Service (ReDoS)

Also known asGHSA-p28h-cc7q-c4fg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-21222.

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.80%1.60%2.40%0.3%1.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

728other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
css-whatnpm
104.6Mdownloads / week

Description

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmcss-whatall versions2.1.3npm install css-what@2.1.3

Affected Products

1 product · 1 configurations
Application
css-whatcss-what_project
< 2.1.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for css-what, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update css-what to 2.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21222 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

UbuntuMEDIUM

Frequently Asked Questions

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.
O3 Security · Impact-Aware SCA

Is CVE-2022-21222 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-21222: css-what DoS — Fixed in 2.1.3