NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-21191 — global-modules-path

HIGHFix: rosen-vladimirov/global-modules-path@edbdaff

CVE-2022-21191 is a high-severity (CVSS 7.4) OS Command Injection vulnerability in global-modules-path. A fix is available for global-modules-path — see the affected versions and patch details below.

global-modules-path Command Injection vulnerability

Also known asGHSA-vvj3-85vf-fgmw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-21191.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.15%0.78%1.41%2.05%0.7%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

39other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
global-modules-pathnpm
74Kdownloads / week

Description

Versions of the package global-modules-path before 3.0.0 are vulnerable to Command Injection due to missing input sanitization or other checks and sandboxes being employed to the getPath function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmglobal-modules-pathall versions3.0.0npm install global-modules-path@3.0.0

Affected Products

1 product · 1 configurations
Application
global-modules-pathglobal-modules-path_project
< 3.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for global-modules-path, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update global-modules-path to 3.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21191 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Versions of the package global-modules-path before 3.0.0 are vulnerable to Command Injection due to missing input sanitization or other checks and sandboxes being employed to the getPath function.
O3 Security · Impact-Aware SCA

Is CVE-2022-21191 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-21191: global-modules — Fixed in 3.0.0