NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-21129 — nemo-appium

HIGHFix: paypal/nemo-appium@aa271d3

CVE-2022-21129 is a high-severity (CVSS 7.4) OS Command Injection vulnerability in nemo-appium. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nemo-appium — see the affected versions and patch details below.

nemo-appium vulnerable to OS Command Injection

Also known asGHSA-c6rx-gxqv-vr5j
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-21129.

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.64%1.52%2.40%3.27%1.1%2.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
nemo-appiumnpm
67downloads / week

Description

Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function.

Note: In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnemo-appiumall versions0.0.9npm install nemo-appium@0.0.9

Affected Products

1 product · 1 configurations
Application
nemo-appiumpaypal
< 0.0.9
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nemo-appium, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nemo-appium to 0.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21129 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. **Note:** In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.
O3 Security · Impact-Aware SCA

Is CVE-2022-21129 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-21129: nemo-appium — Fixed in 0.0.9