NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2022-2073 — grav

CRITICALFix: getgrav/grav@9d6a2db

CVE-2022-2073 is a critical-severity (CVSS 9.1) Code Injection vulnerability in getgrav/grav. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for getgrav/grav — see the affected versions and patch details below.

Code Injection in getgrav/grav

Also known asGHSA-cxgw-r5jg-7xwq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.9%probability of exploitation in next 30 days
Moderate Risk+0.30%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
9.88%10.4%10.9%11.4%10.4%10.6%10.9%Aug 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘getgrav/grav

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Grav is vulnerable to Server Side Template Injection via Twig. According to a previous vulnerability report, Twig should not render dangerous functions by default, such as system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgetgrav/gravall versions1.7.34composer require getgrav/grav:^1.7.34

Affected Products

1 product · 1 configurations
Application
gravgetgrav
< 1.7.34
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getgrav/grav, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update getgrav/grav to 1.7.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2073 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Grav is vulnerable to Server Side Template Injection via Twig. According to a previous vulnerability report, Twig should not render dangerous functions by default, such as system.
O3 Security · Impact-Aware SCA

Is CVE-2022-2073 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-2073: grav — Fixed in 1.7.34