NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-2054 — nuitka

HIGHFix: nuitka/nuitka@0964774

CVE-2022-2054 is a high-severity (CVSS 8.4) Code Injection vulnerability in nuitka. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nuitka — see the affected versions and patch details below.

Code Injection in nuitka/nuitka

Also known asGHSA-4v3r-hqr9-69jfPYSEC-2022-209
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.68%1.03%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍nuitka

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Nuitka 0.8.4 and prior is vulnerable to command injection. A patch is available and anticipated to be part of the 0.9 release.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInuitkaall versions0.9pip install --upgrade 'nuitka==0.9'

Affected Products

1 product · 1 configurations
Application
nuitkanuitka
< 0.9
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nuitka, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nuitka to 0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2054 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Nuitka 0.8.4 and prior is vulnerable to command injection. A patch is available and anticipated to be part of the `0.9` release.
O3 Security · Impact-Aware SCA

Is CVE-2022-2054 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-2054: nuitka Command Injection — Fixed in 0.9