NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-1997 — rosariosis

HIGHFix: francoisjacquet/rosariosis@6b22c0b

CVE-2022-1997 is a high-severity (CVSS 8.8) Cross-site Scripting (XSS) vulnerability in francoisjacquet/rosariosis. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for francoisjacquet/rosariosis — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Stored in francoisjacquet/rosariosis

Also known asGHSA-wjh9-344g-vc49
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.3%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘francoisjacquet/rosariosis

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) - Stored in GitHub repository francoisjacquet/rosariosis prior to 9.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistfrancoisjacquet/rosariosisall versions9.0composer require francoisjacquet/rosariosis:^9.0

Affected Products

1 product · 1 configurations
Application
rosariosisrosariosis
< 9.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for francoisjacquet/rosariosis, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update francoisjacquet/rosariosis to 9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1997 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository francoisjacquet/rosariosis prior to 9.0.
O3 Security · Impact-Aware SCA

Is CVE-2022-1997 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-1997: rosariosis XSS — Fixed in 9.0