NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-1929 — devcert

HIGHFix: davewasmer/devcert@b076321

CVE-2022-1929 is a high-severity (CVSS 7.5) CWE-1333 vulnerability in devcert. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for devcert — see the affected versions and patch details below.

Regular expression denial of service in devcert

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 21, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.38%0.76%1.14%0.2%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

72other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
devcertnpm
208Kdownloads / week

Description

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdevcertall versions1.2.1npm install devcert@1.2.1

Affected Products

1 product · 1 configurations
Application
devcertdevcert_project
< 1.2.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for devcert, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update devcert to 1.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1929 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method
O3 Security · Impact-Aware SCA

Is CVE-2022-1929 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-1929: devcert DoS — Fixed in 1.2.1