NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-1278 — wildfly

HIGH

CVE-2022-1278 is a high-severity (CVSS 7.5) CWE-1188 vulnerability in org.wildfly.bom:wildfly. A fix is available for org.wildfly.bom:wildfly — see the affected versions and patch details below.

WildFly vulnerable to Insecure Default Initialization of Resource

Also known asBIT-wildfly-2022-1278GHSA-fmq7-gh8v-mjvc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.wildfly.bom:wildfly

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in WildFly, where an attacker can see deployment names, endpoints, and any other data the trace payload may contain.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.wildfly.bom:wildflyall versions27.0.0.Beta1org.wildfly.bom:wildfly:27.0.0.Beta1

Affected Products

8 products · 8 configurations
Application
amqredhat
1 version
2.0
Application
amq onlineredhat
all
Application
integration camel kredhat
all
Application
integration service registryredhat
all
Application
jboss a-mqredhat
1 version
7
Application
jboss enterprise application platform expansion packredhat
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly.bom:wildfly, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.wildfly.bom:wildfly to 27.0.0.Beta1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1278 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
AMQ Broker 7.11.0WildFlyRHSA-2023:1661
Red Hat JBoss Enterprise Application Platform Expansion Packsee advisoryRHSA-2023:1855

Frequently Asked Questions

A flaw was found in WildFly, where an attacker can see deployment names, endpoints, and any other data the trace payload may contain.
O3 Security · Impact-Aware SCA

Is CVE-2022-1278 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-1278: wildfly — Fixed in 27.0.0.Beta1