NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-1274 — keycloak-services

MEDIUMFix: keycloak/keycloak#16764

CVE-2022-1274 is a medium-severity (CVSS 5.4) CWE-80 vulnerability in org.keycloak:keycloak-services. A fix is available for org.keycloak:keycloak-services — see the affected versions and patch details below.

HTML Injection in Keycloak Admin REST API

Also known asGHSA-m4fv-gm5m-4725
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.19%0.63%1.06%1.49%0.9%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.keycloak:keycloak-services

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Keycloak in the execute-actions-email endpoint. This issue allows arbitrary HTML to be injected into emails sent to Keycloak users and can be misused to perform phishing or other attacks against users.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.keycloak:keycloak-servicesall versions20.0.5org.keycloak:keycloak-services:20.0.5

Affected Products

3 products · 5 configurations
Application
keycloakredhat
< 20.0.5
range
Application
openshift container platformredhat
2 versions
4.94.10
Application
single sign-onredhat
≥ 7.6 && < 7.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-services, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.keycloak:keycloak-services to 20.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1274 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Single Sign-On 7rh-sso7-keycloakRHSA-2023:1049
Red Hat Single Sign-On 7.6 for RHEL 7rh-sso7-keycloak-0:18.0.6-1.redhat_00001.1.el7ssoRHSA-2023:1043
Red Hat Single Sign-On 7.6 for RHEL 8rh-sso7-keycloak-0:18.0.6-1.redhat_00001.1.el8ssoRHSA-2023:1044
Red Hat Single Sign-On 7.6 for RHEL 9rh-sso7-keycloak-0:18.0.6-1.redhat_00001.1.el9ssoRHSA-2023:1045
RHEL-8 based Middleware Containersrh-sso-7/sso76-openshift-rhel8:7.6-20RHSA-2023:1047

Frequently Asked Questions

A flaw was found in Keycloak in the execute-actions-email endpoint. This issue allows arbitrary HTML to be injected into emails sent to Keycloak users and can be misused to perform phishing or other attacks against users.
O3 Security · Impact-Aware SCA

Is CVE-2022-1274 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-1274: keycloak-services — Fixed in 20.0.5