NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-0985 — moodle

MEDIUMFix: moodle/moodle@addd4f8

CVE-2022-0985 is a medium-severity (CVSS 4.3) Improper Authentication vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Improper Authentication in moodle

Also known asBIT-moodle-2022-0985GHSA-6q9g-3vfq-q2qj
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.71%1.07%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.11.0&&< 3.11.63.11.6composer require moodle/moodle:^3.11.6
🐘Packagistmoodle/moodle≥ 3.10.0&&< 3.10.103.10.10composer require moodle/moodle:^3.10.10
🐘Packagistmoodle/moodle≥ 3.9&&< 3.9.133.9.13composer require moodle/moodle:^3.9.13

Affected Products

1 product · 3 configurations
Application
moodlemoodle
≥ 3.11.0 && < 3.11.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.11.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0985 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
O3 Security · Impact-Aware SCA

Is CVE-2022-0985 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-0985: moodle — Fixed in 3.11.6