CVE-2022-0984 is a medium-severity (CVSS 4.3) CWE-863 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Missing authorization in Moodle
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Users with the capability to configure badge criteria (teachers and managers by default) were able to configure course badges with profile field criteria, which should only be available for site badges.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.11.0&&< 3.11.6 | 3.11.6composer require moodle/moodle:^3.11.6 |
| 🐘Packagist | moodle/moodle | ≥ 3.10.0&&< 3.10.10 | 3.10.10composer require moodle/moodle:^3.10.10 |
| 🐘Packagist | moodle/moodle | all versions | 3.9.13composer require moodle/moodle:^3.9.13 |
Affected Products
fedorafedoraprojectmoodlemoodleenterprise linuxredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.11.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0984 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-0984 in your dependencies?
Find it across Packagist, including transitive dependencies.