NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-0983 — moodle

HIGHFix: moodle/moodle@c279475

CVE-2022-0983 is a high-severity (CVSS 8.8) SQL Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

SQL Injection in Moodle

Also known asBIT-moodle-2022-0983GHSA-h2fw-93qx-vrcq
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.48%0.96%1.43%0.4%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An SQL injection risk was identified in Badges code relating to configuring criteria. Access to the relevant capability was limited to teachers and managers by default.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.11.0&&< 3.11.63.11.6composer require moodle/moodle:^3.11.6
🐘Packagistmoodle/moodle≥ 3.10.0&&< 3.10.103.10.10composer require moodle/moodle:^3.10.10
🐘Packagistmoodle/moodleall versions3.9.13composer require moodle/moodle:^3.9.13

Affected Products

3 products · 6 configurations
Application
extra packages for enterprise linuxfedoraproject
1 version
7.0
OS
fedorafedoraproject
2 versions
3536
Application
moodlemoodle
≥ 3.11.0 && < 3.11.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.11.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0983 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

An SQL injection risk was identified in Badges code relating to configuring criteria. Access to the relevant capability was limited to teachers and managers by default.
O3 Security · Impact-Aware SCA

Is CVE-2022-0983 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-0983: moodle SQL Injection — Fixed in 3.11.6