NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-0954 — microweber

MEDIUMFix: microweber/microweber@955471c

CVE-2022-0954 is a medium-severity (CVSS 6.8) Cross-site Scripting (XSS) vulnerability in microweber/microweber. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for microweber/microweber — see the affected versions and patch details below.

Multiple Stored Cross-site Scripting (XSS) Vulnerabilities in Shop's Other Settings, Shop's Autorespond E-mail Settings and Shops' Payments Methods in microweber/microweber

Also known asGHSA-8c76-mxv5-w4g8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
2.70%3.38%4.07%4.76%4.3%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘microweber/microweber

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple Stored Cross-site Scripting (XSS) Vulnerabilities in Shop's Other Settings, Shop's Autorespond E-mail Settings and Shops' Payments Methods in GitHub repository microweber/microweber prior to 1.2.11.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmicroweber/microweberall versions1.2.12composer require microweber/microweber:^1.2.12

Affected Products

1 product · 1 configurations
Application
microwebermicroweber
< 1.2.11
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for microweber/microweber, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update microweber/microweber to 1.2.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0954 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2022-0954

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2022-0954 -u https://target
Template
Microweber <1.2.11 - Stored Cross-Site Scripting
Severity
medium
Impact
Successful exploitation of this vulnerability could allow an attacker to execute malicious scripts in the context of the victim's browser, leading to potential data theft, session hijacking, or defacement of the affected website.
Remediation
Upgrade Microweber to version 1.2.11 or later to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (amit-jd), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Multiple Stored Cross-site Scripting (XSS) Vulnerabilities in Shop's Other Settings, Shop's Autorespond E-mail Settings and Shops' Payments Methods in GitHub repository microweber/microweber prior to 1.2.11.
O3 Security · Impact-Aware SCA

Is CVE-2022-0954 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-0954: microweber XSS — Fixed in 1.2.12