CVE-2022-0697 is a low-severity (CVSS 3.4) Open Redirect vulnerability in archivy. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for archivy — see the affected versions and patch details below.
Open Redirect in archivy/archivy
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
archivyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Open Redirect in GitHub repository archivy/archivy prior to 1.7.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | archivy | all versions | 1.7.1pip install --upgrade 'archivy==1.7.1' |
Affected Products
archivyarchivy_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for archivy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update archivy to 1.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0697 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is CVE-2022-0697 in your dependencies?
Find it across PyPI, including transitive dependencies.