NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-0394 — livehelperchat

MEDIUMFix: livehelperchat/livehelperchat@d7b8546

CVE-2022-0394 is a medium-severity (CVSS 5.3) Cross-site Scripting (XSS) vulnerability in remdex/livehelperchat. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for remdex/livehelperchat — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Stored in livehelperchat/livehelperchat

Also known asBIT-livehelperchat-2022-0394GHSA-vwxp-9qmf-w299
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-0394.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.3%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘remdex/livehelperchat

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

LiveHelperChat (remdex/livehelperchat in Packagist) has a stored Cross-site Scripting (XSS) vulnerability prior to version 3.93.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistremdex/livehelperchatall versions3.93composer require remdex/livehelperchat:^3.93

Affected Products

1 product · 1 configurations
Application
live helper chatlivehelperchat
< 3.93
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for remdex/livehelperchat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update remdex/livehelperchat to 3.93 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0394 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

LiveHelperChat (remdex/livehelperchat in Packagist) has a stored Cross-site Scripting (XSS) vulnerability prior to version 3.93.
O3 Security · Impact-Aware SCA

Is CVE-2022-0394 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-0394: livehelperchat XSS — Fixed in 3.93