NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2022-0225 — keycloak-core

CVE-2022-0225 is a Cross-site Scripting (XSS) vulnerability in org.keycloak:keycloak-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.keycloak:keycloak-core — see the affected versions and patch details below.

Stored Cross-Site Scripting (XSS) in Keycloak via groups dropdown

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.34%2.67%4.01%0.5%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.keycloak:keycloak-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A Stored XSS vulnerability was reported in the Keycloak Security mailing list, affecting all the versions of Keycloak, including the latest release (16.0.1). The vulnerability allows a privileged attacker to execute malicious scripts in the admin console, abusing of the groups' dropdown functionality.

Impact

Successful attacks of this vulnerability can result a privileged attacker to load a XSS script, and steal data from other users. The impact can be considered moderate to low, considering privileged credentials are required.

References

  • Please refer to the Keycloak Security mailing list for more information.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.keycloak:keycloak-coreall versions20.0.0org.keycloak:keycloak-core:20.0.0

Affected Products

2 products · 2 configurations
Application
keycloakredhat
all
Application
single sign-onredhat
1 version
7.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.keycloak:keycloak-core to 20.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0225 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Single Sign-On 7rh-sso7-keycloakRHSA-2022:6787
Red Hat Single Sign-On 7.5 for RHEL 7rh-sso7-keycloak-0:15.0.8-1.redhat_00001.1.el7ssoRHSA-2022:6782
Red Hat Single Sign-On 7.5 for RHEL 8rh-sso7-keycloak-0:15.0.8-1.redhat_00001.1.el8ssoRHSA-2022:6783
Red Hat Single Sign-On 7.6.1rh-sso7-keycloakRHSA-2022:7417
Red Hat Single Sign-On 7.6 for RHEL 7rh-sso7-keycloak-0:18.0.3-1.redhat_00001.1.el7ssoRHSA-2022:7409
Red Hat Single Sign-On 7.6 for RHEL 8rh-sso7-keycloak-0:18.0.3-1.redhat_00001.1.el8ssoRHSA-2022:7410
Red Hat Single Sign-On 7.6 for RHEL 9rh-sso7-0:1-5.el9ssoRHSA-2022:7411

Frequently Asked Questions

### Summary A Stored XSS vulnerability was reported in the Keycloak Security mailing list, affecting all the versions of Keycloak, including the latest release (16.0.1). The vulnerability allows a privileged attacker to execute malicious scripts in the admin console, abusing of the groups' dropdown functionality. ### Impact Successful attacks of this vulnerability can result a privileged attacker to load a XSS script, and steal data from other users. The impact can be considered moderate to low, considering privileged credentials are required. ### References - Please refer to the Keycloak
O3 Security · Impact-Aware SCA

Is CVE-2022-0225 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-0225: keycloak-core XSS — Fixed in 20.0.0