NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2021-43812 — @auth0/nextjs-auth0

MEDIUMFix: auth0/nextjs-auth0@0bbd9f8

CVE-2021-43812 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in @auth0/nextjs-auth0. A fix is available for @auth0/nextjs-auth0 — see the affected versions and patch details below.

Open redirect in @auth0/nextjs-auth0

Also known asGHSA-2mqv-4j3r-vjvp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.78%1.18%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

41other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@auth0/nextjs-auth0npm
1.3Mdownloads / week

Description

Overview

Versions <=1.6.1 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability.

Am I affected?

You are affected by this vulnerability if you are using @auth0/nextjs-auth0 version <=1.6.1.

How to fix that?

Upgrade to version >=1.6.2

Will this update impact my users?

The fix provided in the patch will not affect your users.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@auth0/nextjs-auth0all versions1.6.2npm install @auth0/nextjs-auth0@1.6.2

Affected Products

1 product · 1 configurations
Application
nextjs-auth0auth0
< 1.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @auth0/nextjs-auth0, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @auth0/nextjs-auth0 to 1.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-43812 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

### Overview Versions `<=1.6.1` do not filter out certain `returnTo` parameter values from the login url, which expose the application to an open redirect vulnerability. ### Am I affected? You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `<=1.6.1`. ### How to fix that? Upgrade to version `>=1.6.2` ### Will this update impact my users? The fix provided in the patch will not affect your users.
O3 Security · Impact-Aware SCA

Is CVE-2021-43812 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-43812: @auth0/nextjs — Fixed in 1.6.2