NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2021-43783 — @backstage/plugin-scaffol…

HIGHFix: backstage/backstage@f9352ab

CVE-2021-43783 is a high-severity (CVSS 8.5) Path Traversal vulnerability in @backstage/plugin-scaffolder-backend. A fix is available for @backstage/plugin-scaffolder-backend — see the affected versions and patch details below.

Path Traversal in @backstage/plugin-scaffolder-backend

Also known asGHSA-mg3m-f475-28hv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.75%0.4%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

69other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@backstage/plugin-scaffolder-backendnpm
197Kdownloads / week

Description

Impact

A malicious actor with write access to a registered scaffolder template is able to manipulate the template in a way that writes files to arbitrary paths on the scaffolder-backend host instance.

This vulnerability can in some situation also be exploited through user input when executing a template, meaning you do not need write access to the templates. This method will not allow the attacker to control the contents of the injected file however, unless the template is also crafted in a specific way that gives control of the file contents.

Patches

This vulnerability is fixed in version 0.15.14 of the @backstage/plugin-scaffolder-backend.

Workarounds

This attack is mitigated by restricting access and requiring reviews when registering or modifying scaffolder templates.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@backstage/plugin-scaffolder-backendall versions0.15.14npm install @backstage/plugin-scaffolder-backend@0.15.14

Affected Products

1 product · 1 configurations
Application
backstagelinuxfoundation
< 0.15.14
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @backstage/plugin-scaffolder-backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @backstage/plugin-scaffolder-backend to 0.15.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-43783 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact A malicious actor with write access to a registered scaffolder template is able to manipulate the template in a way that writes files to arbitrary paths on the scaffolder-backend host instance. This vulnerability can in some situation also be exploited through user input when executing a template, meaning you do not need write access to the templates. This method will not allow the attacker to control the contents of the injected file however, unless the template is also crafted in a specific way that gives control of the file contents. ### Patches This vulnerability is fixed in v
O3 Security · Impact-Aware SCA

Is CVE-2021-43783 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-43783: @backstage/plugin — Fixed in 0.15.14