CVE-2021-43667 is a high-severity (CVSS 7.5) NULL Pointer Dereference vulnerability in github.com/hyperledger/fabric. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/hyperledger/fabric — see the affected versions and patch details below.
NULL Pointer Dereference in HyperLedger Fabric
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hyperledger/fabric🐹github.com/hyperledger/fabricReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.1.0. This bug can be leveraged by constructing a message whose payload is nil and sending this message with the method 'forwardToLeader'. This bug has been admitted and fixed by the developers of Fabric. If leveraged, any leader node will crash.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hyperledger/fabric | ≥ 2.3.0&&< 2.3.3 | 2.3.3go get github.com/hyperledger/fabric@v2.3.3 |
| 🐹Go | github.com/hyperledger/fabric | all versions | 2.2.4go get github.com/hyperledger/fabric@v2.2.4 |
Affected Products
fabriclinuxfoundationResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hyperledger/fabric, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hyperledger/fabric to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-43667 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-43667 in your dependencies?
Find it across Go, including transitive dependencies.