CVE-2021-43560 — moodle
MEDIUMCVE-2021-43560 is a medium-severity (CVSS 5.3) CWE-863 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle Insecure direct object reference (IDOR) in a calendar web service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.9&&< 3.9.11 | 3.9.11composer require moodle/moodle:^3.9.11 |
| 🐘Packagist | moodle/moodle | ≥ 3.10&&< 3.10.8 | 3.10.8composer require moodle/moodle:^3.10.8 |
| 🐘Packagist | moodle/moodle | ≥ 3.11&&< 3.11.4 | 3.11.4composer require moodle/moodle:^3.11.4 |
Affected Products
extra packages for enterprise linuxfedoraprojectfedorafedoraprojectmoodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.9.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-43560 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2021-43560 in your dependencies?
Find it across Packagist, including transitive dependencies.