NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2021-4326 — @zowe/imperative

HIGHFix: zowe/imperative#900

CVE-2021-4326 is a high-severity (CVSS 7.8) vulnerability in @zowe/imperative. A fix is available for @zowe/imperative — see the affected versions and patch details below.

Imperative CLI vulnerable to Command Injection

Also known asGHSA-6q8m-42qq-64r7
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.25%0.50%0.76%0.1%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@zowe/imperativenpm
5Kdownloads / week

Description

A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npm@zowe/imperative≥ 5.0.0&&< 5.7.15.7.1npm install @zowe/imperative@5.7.1
📦npm@zowe/imperativeall versions4.18.10npm install @zowe/imperative@4.18.10

Affected Products

1 product · 2 configurations
Application
zowelinuxfoundation
≥ 2.0.0 && < 2.5.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @zowe/imperative, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @zowe/imperative to 5.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-4326 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.
O3 Security · Impact-Aware SCA

Is CVE-2021-4326 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-4326: @zowe/imperative — Fixed in 5.7.1