NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2021-42134 — django-unicorn

MEDIUMFix: adamghill/django-unicorn@3a832a9

CVE-2021-42134 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in django-unicorn. A fix is available for django-unicorn — see the affected versions and patch details below.

Cross-site Scripting in django-unicorn

Also known asGHSA-ggmv-6q9p-9gm6PYSEC-2021-369
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.80%1.20%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍django-unicorn

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The Unicorn framework before 0.36.1 for Django allows XSS via a component. NOTE: this issue exists because of an incomplete fix for CVE-2021-42053.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango-unicornall versions0.36.1pip install --upgrade 'django-unicorn==0.36.1'

Affected Products

1 product · 1 configurations
Application
unicorndjango-unicorn
< 0.36.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django-unicorn, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django-unicorn to 0.36.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-42134 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The Unicorn framework before 0.36.1 for Django allows XSS via a component. NOTE: this issue exists because of an incomplete fix for CVE-2021-42053.
O3 Security · Impact-Aware SCA

Is CVE-2021-42134 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2021-42134: django-unicorn XSS — Fixed in 0.36.1