NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-41571 — pulsar

MEDIUMFix: apache/pulsar#11852

CVE-2021-41571 is a medium-severity (CVSS 6.5) CWE-863 vulnerability in org.apache.pulsar:pulsar. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.pulsar:pulsar — see the affected versions and patch details below.

Improper Input Validation in Apache Pulsar

Also known asGHSA-3whx-qrj5-hh2h
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.48%1.08%1.68%2.27%1.0%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.pulsar:pulsar☕org.apache.pulsar:pulsar☕org.apache.pulsar:pulsar

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Pulsar it is possible to access data from BookKeeper that does not belong to the topics accessible by the authenticated user. The Admin API get-message-by-id requires the user to input a topic and a ledger id. The ledger id is a pointer to the data, and it is supposed to be a valid it for the topic. Authorisation controls are performed against the topic name and there is not proper validation the that ledger id is valid in the context of such ledger. So it may happen that the user is able to read from a ledger that contains data owned by another tenant. This issue affects Apache Pulsar Apache Pulsar version 2.8.0 and prior versions; Apache Pulsar version 2.7.3 and prior versions; Apache Pulsar version 2.6.4 and prior versions.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.pulsar:pulsarall versionsNo fix
☕Mavenorg.apache.pulsar:pulsar≥ 2.7.0&&< 2.7.42.7.4org.apache.pulsar:pulsar:2.7.4
☕Mavenorg.apache.pulsar:pulsar≥ 2.8.0&&< 2.8.12.8.1org.apache.pulsar:pulsar:2.8.1

Affected Products

1 product · 3 configurations
Application
pulsarapache
≥ 2.7.0 && < 2.7.3
1 version
2.8.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2021-41571; check the affected-versions list above or the advisory for the patched release of org.apache.pulsar:pulsar, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

In Apache Pulsar it is possible to access data from BookKeeper that does not belong to the topics accessible by the authenticated user. The Admin API get-message-by-id requires the user to input a topic and a ledger id. The ledger id is a pointer to the data, and it is supposed to be a valid it for the topic. Authorisation controls are performed against the topic name and there is not proper validation the that ledger id is valid in the context of such ledger. So it may happen that the user is able to read from a ledger that contains data owned by another tenant. This issue affects Apache Puls
O3 Security · Impact-Aware SCA

Is CVE-2021-41571 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-41571: pulsar — Fixed in 2.7.4