NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2021-41104 — esphome

HIGHFix: esphome/esphome#2409

CVE-2021-41104 is a high-severity (CVSS 7.5) Missing Authentication vulnerability in esphome. A fix is available for esphome — see the affected versions and patch details below.

Basic auth bypass in esphome

Also known asPYSEC-2021-351
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.57%1.14%1.71%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍esphome

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

ESPHome is a system to control the ESP8266/ESP32. Anyone with web_server enabled and HTTP basic auth configured on version 2021.9.1 or older is vulnerable to an issue in which web_server allows over-the-air (OTA) updates without checking user defined basic auth username & password. This issue is patched in version 2021.9.2. As a workaround, one may disable or remove web_server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIesphomeall versions2021.9.2pip install --upgrade 'esphome==2021.9.2'

Affected Products

1 product · 1 configurations
OS
esphome firmwareesphome
< 2021.9.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for esphome, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update esphome to 2021.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-41104 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact Anyone with web_server enabled and HTTP basic auth configured on 2021.9.1 or older `web_server` allows OTA update without checking user defined basic auth username & password ### Patches Patch released in 2021.9.2 ### Workarounds Disable/remove `web_server`
O3 Security · Impact-Aware SCA

Is CVE-2021-41104 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2021-41104: esphome — Fixed in 2021.9.2