CVE-2021-40720 — ops-cli
CRITICALCVE-2021-40720 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in ops-cli. A fix is available for ops-cli — see the affected versions and patch details below.
Ops CLI Deserialization of Untrusted Data vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ops-cliReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ops-cli | all versions | 2.0.5pip install --upgrade 'ops-cli==2.0.5' |
Affected Products
ops-cliadobeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ops-cli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ops-cli to 2.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-40720 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2021-40720 in your dependencies?
Find it across PyPI, including transitive dependencies.