NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-39864 — community-edition

MEDIUM

CVE-2021-39864 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento Open Source allows Cross-Site Request Forgery (CSRF)

Also known asGHSA-94wq-87g6-8h77
Published
Updated
Affected
5 pkgs
Patched
1 / 5
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2021-39864.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.50%1.04%1.58%2.12%1.0%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/project-community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.2-p2 (and earlier), 2.4.3 (and earlier) and 2.3.7p1 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via a Wishlist Share Link. Successful exploitation could lead to unauthorized addition to a customer's cart by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.

Affected Packages

5 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.4.2-p1No fix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versions2.3.7-p2composer require magento/community-edition:^2.3.7-p2
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/project-community-editionall versionsNo fix

Affected Products

2 products · 12 configurations
Application
commerceadobe
≤ 2.3.7
3 versions
2.3.72.4.22.4.3
Application
magento open sourceadobe
≤ 2.3.7
3 versions
2.3.72.4.22.4.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2021-39864; check the affected-versions list above or the advisory for the patched release of magento/community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Adobe Commerce versions 2.4.2-p2 (and earlier), 2.4.3 (and earlier) and 2.3.7p1 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via a Wishlist Share Link. Successful exploitation could lead to unauthorized addition to a customer's cart by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.
O3 Security · Impact-Aware SCA

Is CVE-2021-39864 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-39864: community CSRF — Fixed in 2.3.7-p2