NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-3914 — smallrye-health-ui

MEDIUMFix: smallrye/smallrye-health#333

CVE-2021-3914 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in io.smallrye:smallrye-health-ui. A fix is available for io.smallrye:smallrye-health-ui — see the affected versions and patch details below.

SmallRye Health UI Cross-site Scripting vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.68%1.02%0.5%0.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.smallrye:smallrye-health-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It was found that the smallrye health metrics UI component did not properly sanitize some user inputs. An attacker could use this flaw to conduct cross-site scripting attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.smallrye:smallrye-health-uiall versions3.1.2io.smallrye:smallrye-health-ui:3.1.2

Affected Products

3 products · 4 configurations
Application
build of quarkusredhat
< 2.7.5
range
Application
openshift application runtimesredhat
1 version
1.0
Application
smallrye healthredhat
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.smallrye:smallrye-health-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.smallrye:smallrye-health-ui to 3.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3914 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat build of Quarkus 2.7.5smallrye-health-uiRHSA-2022:4623

Frequently Asked Questions

It was found that the smallrye health metrics UI component did not properly sanitize some user inputs. An attacker could use this flaw to conduct cross-site scripting attacks.
O3 Security · Impact-Aware SCA

Is CVE-2021-3914 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-3914: smallrye-health-ui XSS — Fixed in 3.1.2