NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2021-3869 — stanford-corenlp

HIGHFix: stanfordnlp/corenlp@5d83f1e

CVE-2021-3869 is a high-severity (CVSS 7.5) XML External Entity (XXE) vulnerability in edu.stanford.nlp:stanford-corenlp. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for edu.stanford.nlp:stanford-corenlp — see the affected versions and patch details below.

Improper Restriction of XML External Entity Reference in Stanford CoreNLP

Also known asGHSA-8gf7-w3cp-gfh3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.62%1.24%1.86%0.3%1.4%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕edu.stanford.nlp:stanford-corenlp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

corenlp is vulnerable to Improper Restriction of XML External Entity Reference

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenedu.stanford.nlp:stanford-corenlpall versions4.3.1edu.stanford.nlp:stanford-corenlp:4.3.1

Affected Products

1 product · 1 configurations
Application
corenlpstanford
≤ 4.3.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for edu.stanford.nlp:stanford-corenlp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update edu.stanford.nlp:stanford-corenlp to 4.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3869 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

corenlp is vulnerable to Improper Restriction of XML External Entity Reference
O3 Security · Impact-Aware SCA

Is CVE-2021-3869 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-3869: stanford-corenlp XXE — Fixed in 4.3.1