NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2021-38540 — apache-airflow

CRITICALFix: apache/airflow@bcec1df

CVE-2021-38540 is a critical-severity (CVSS 9.8) Improper Privilege Management vulnerability in apache-airflow. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for apache-airflow — see the affected versions and patch details below.

Missing Authentication for Critical Function in Apache Airflow

Also known asBIT-airflow-2021-38540GHSA-h88f-r7cw-8fv3PYSEC-2021-326
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
80.9%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
77.7%83.5%89.3%95.0%91.8%80.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍apache-airflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The variable import endpoint was not protected by authentication in Airflow >=2.0.0, <2.1.3. This allowed unauthenticated users to hit that endpoint to add/modify Airflow variables used in DAGs, potentially resulting in a denial of service, information disclosure or remote code execution. This issue affects Apache Airflow >=2.0.0, <2.1.3.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIapache-airflow≥ 2.0.0&&< 2.1.32.1.3pip install --upgrade 'apache-airflow==2.1.3'

Affected Products

1 product · 1 configurations
Application
airflowapache
≥ 2.0.0 && < 2.1.3
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-airflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apache-airflow to 2.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-38540 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

How to detect CVE-2021-38540

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2021-38540 -u https://target
Template
Apache Airflow - Unauthenticated Variable Import
Severity
critical
Impact
An attacker can exploit this vulnerability to import malicious variables, potentially gaining unauthorized access to sensitive data.
Remediation
Upgrade to Apache Airflow 2.1.3 or higher.

Template by ProjectDiscovery nuclei-templates (pdteam), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

The variable import endpoint was not protected by authentication in Airflow >=2.0.0, <2.1.3. This allowed unauthenticated users to hit that endpoint to add/modify Airflow variables used in DAGs, potentially resulting in a denial of service, information disclosure or remote code execution. This issue affects Apache Airflow >=2.0.0, <2.1.3.
O3 Security · Impact-Aware SCA

Is CVE-2021-38540 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2021-38540: apache-airflow RCE — Fixed in 2.1.3