CVE-2021-36778 — rancher
HIGHCVE-2021-36778 is a high-severity (CVSS 7.5) CWE-863 vulnerability in github.com/rancher/rancher. A fix is available for github.com/rancher/rancher — see the affected versions and patch details below.
Exposure of repository credentials to external third-party sources in Rancher
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/rancher/rancher🐹github.com/rancher/rancherReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
This issue only happens when the user configures access credentials to a private repository in Rancher inside Apps & Marketplace > Repositories. It affects Rancher versions 2.5.0 up to and including 2.5.11 and from 2.6.0 up to and including 2.6.2.
An insufficient check of the same-origin policy when downloading Helm charts from a configured private repository can lead to exposure of the repository credentials to a third-party provider. This exposure happens when the private repository:
- Does an HTTP redirect to a third-party repository or external storage provider.
- Downloads an icon resource for the chart hosted on a third-party provider.
The address of the private repository is not leaked, only the credentials are leaked in the HTTP Authorization header in base64 format.
With the patched versions, the default behavior now is to only send the private repository credentials when subdomain or domain hostname match when following the redirect or downloading external resources.
Patches
Patched versions include releases 2.5.12, 2.6.3 and later versions.
Workarounds
- Update Rancher to a patched version.
- Check the Helm charts in your configured private repository for possible redirects to third-party storage, and for Helm chart icons from third-party sources.
- Evaluate any Helm chart that might lead to the mentioned scenario and change affected credentials if deemed necessary.
References
Information about the same-origin check and how to disable it is available in Rancher documentation.
For more information
If you have any questions or comments about this advisory:
- Reach out to SUSE Rancher Security team for security related inquiries.
- Open an issue in Rancher repository.
- Verify our support matrix and product support lifecycle.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/rancher | ≥ 2.6.0&&< 2.6.3 | 2.6.3go get github.com/rancher/rancher@v2.6.3 |
| 🐹Go | github.com/rancher/rancher | ≥ 2.5.0&&< 2.5.12 | 2.5.12go get github.com/rancher/rancher@v2.5.12 |
Affected Products
ranchersuseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/rancher, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/rancher to 2.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-36778 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2021-36778 in your dependencies?
Find it across Go, including transitive dependencies.