CVE-2021-36711 — octobot
CRITICALCVE-2021-36711 is a critical-severity (CVSS 9.8) Unrestricted File Upload vulnerability in octobot. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for octobot — see the affected versions and patch details below.
Octobot mishandles Tentacles upload
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
octobotReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
WebInterface in OctoBot before 0.4.4 allows remote code execution because Tentacles upload is mishandled.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | octobot | all versions | 0.4.4pip install --upgrade 'octobot==0.4.4' |
Affected Products
octobotoctobotResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
OctoBot WebInterface 0.4.3 - Remote Code Execution (RCE)
by Samy Younsi · Jul 21, 2022
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for octobot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update octobot to 0.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-36711 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is CVE-2021-36711 in your dependencies?
Find it across PyPI, including transitive dependencies.