NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-3642 — wildfly-elytron

MEDIUM

CVE-2021-3642 is a medium-severity (CVSS 5.3) CWE-203 vulnerability in org.wildfly.security:wildfly-elytron. A fix is available for org.wildfly.security:wildfly-elytron — see the affected versions and patch details below.

Observable Discrepancy in Wildfly Elytron

Also known asGHSA-5499-qjvh-6j7w
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.3%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.wildfly.security:wildfly-elytron☕org.wildfly.security:wildfly-elytron☕org.wildfly.security:wildfly-elytron

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Wildfly Elytron where ScramServer may be susceptible to Timing Attack if enabled. The highest threat of this vulnerability is confidentiality. This flaw affectes Wildfly Elytron versions prior to 1.10.14.Final, prior to 1.15.5.Final and prior to 1.16.1.Final.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.wildfly.security:wildfly-elytronall versions1.10.14org.wildfly.security:wildfly-elytron:1.10.14
☕Mavenorg.wildfly.security:wildfly-elytron≥ 1.11.0&&< 1.15.51.15.5org.wildfly.security:wildfly-elytron:1.15.5
☕Mavenorg.wildfly.security:wildfly-elytron≥ 1.16.0&&< 1.16.11.16.1org.wildfly.security:wildfly-elytron:1.16.1

Affected Products

13 products · 15 configurations
Application
quarkusquarkus
≤ 2.1.4
range
Application
build of quarkusredhat
all
Application
codeready studioredhat
1 version
12.0
Application
data gridredhat
1 version
8.0
Application
descision managerredhat
1 version
7.0
Application
integration camel kredhat
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly.security:wildfly-elytron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.wildfly.security:wildfly-elytron to 1.10.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3642 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
EAP 7.3.10 GAwildfly-elytronRHSA-2021:5154
Red Hat build of Quarkus 2.2.3wildfly-elytronRHSA-2021:3880
Red Hat Data Grid 8.3.0wildfly-elytronRHSA-2022:0520
Red Hat EAP-XP 2 via EAP 7.3.x basewildfly-elytronRHSA-2022:0146
Red Hat Fuse 7.11wildfly-elytronRHSA-2022:5532
Red Hat Integration Camel Quarkus 2see advisoryRHSA-2021:4767
Red Hat JBoss Enterprise Application Platformorg.wildfly.security/wildfly-elytron:1.15.5.Final-redhat-00001RHSA-2021:3660
Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6eap7-apache-cxf-0:3.3.12-1.redhat_00001.1.el6eapRHSA-2021:5149

Frequently Asked Questions

A flaw was found in Wildfly Elytron where ScramServer may be susceptible to Timing Attack if enabled. The highest threat of this vulnerability is confidentiality. This flaw affectes Wildfly Elytron versions prior to 1.10.14.Final, prior to 1.15.5.Final and prior to 1.16.1.Final.
O3 Security · Impact-Aware SCA

Is CVE-2021-3642 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-3642: wildfly-elytron — Fixed in 1.10.14