CVE-2021-36394 — moodle
CRITICALCVE-2021-36394 is a critical-severity (CVSS 9.8) CWE-384 vulnerability in moodle/moodle. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle Session Fixation vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Moodle, a remote code execution risk was identified in the Shibboleth authentication plugin.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.11.0-beta&&< 3.11.1 | 3.11.1composer require moodle/moodle:^3.11.1 |
| 🐘Packagist | moodle/moodle | ≥ 3.10.0-beta&&< 3.10.5 | 3.10.5composer require moodle/moodle:^3.10.5 |
| 🐘Packagist | moodle/moodle | all versions | 3.9.8composer require moodle/moodle:^3.9.8 |
Affected Products
moodlemoodleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-36394 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2021-36394 in your dependencies?
Find it across Packagist, including transitive dependencies.