NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-36038 — project-community-edition

MEDIUM

CVE-2021-36038 is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in magento/project-community-edition. A fix is available for magento/project-community-edition — see the affected versions and patch details below.

Magento discloses sensitive information via the Multishipping Module

Also known asGHSA-wgpr-9675-8r67
Published
Updated
Affected
5 pkgs
Patched
2 / 5
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.96%1.40%1.84%2.29%1.5%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘magento/project-community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability in the Multishipping Module. An authenticated attacker could leverage this vulnerability to achieve sensitive information disclosure.

Affected Packages

5 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/project-community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versions2.3.7-p1composer require magento/community-edition:^2.3.7-p1
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.2-p1&&< 2.4.2-p22.4.2-p2composer require magento/community-edition:^2.4.2-p2
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

2 products · 6 configurations
Application
adobe commerceadobe
≥ 2.4.0 && ≤ 2.4.2
1 version
2.4.2
Application
magento open sourceadobe
≥ 2.4.0 && ≤ 2.4.2
1 version
2.4.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/project-community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2021-36038; check the affected-versions list above or the advisory for the patched release of magento/project-community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability in the Multishipping Module. An authenticated attacker could leverage this vulnerability to achieve sensitive information disclosure.
O3 Security · Impact-Aware SCA

Is CVE-2021-36038 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-36038: project-community — Fixed in 2.3.7-p1