NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2021-36022 — project-community-edition

HIGH

CVE-2021-36022 is a high-severity (CVSS 7.2) OS Command Injection vulnerability in magento/project-community-edition. A fix is available for magento/project-community-edition — see the affected versions and patch details below.

Magento XML Injection vulnerability in the Widgets Update Layout

Also known asGHSA-3x9x-vhqj-cv27
Published
Updated
Affected
5 pkgs
Patched
2 / 5
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
1.07%5.28%9.49%13.7%11.3%3.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘magento/project-community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Update Layout. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.

Affected Packages

5 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/project-community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versions2.3.7-p1composer require magento/community-edition:^2.3.7-p1
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.2-p1&&< 2.4.2-p22.4.2-p2composer require magento/community-edition:^2.4.2-p2
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

2 products · 6 configurations
Application
adobe commerceadobe
≥ 2.4.0 && ≤ 2.4.2
1 version
2.4.2
Application
magento open sourceadobe
≥ 2.4.0 && ≤ 2.4.2
1 version
2.4.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/project-community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2021-36022; check the affected-versions list above or the advisory for the patched release of magento/project-community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Update Layout. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.
O3 Security · Impact-Aware SCA

Is CVE-2021-36022 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-36022: project-community — Fixed in 2.3.7-p1