CVE-2021-3597 — undertow-core
MEDIUMCVE-2021-3597 is a medium-severity (CVSS 5.9) CWE-362 vulnerability in io.undertow:undertow-core. A fix is available for io.undertow:undertow-core — see the affected versions and patch details below.
undertow Race Condition vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.undertow:undertow-core☕io.undertow:undertow-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in undertow. The HTTP2SourceChannel fails to write the final frame under some circumstances, resulting in a denial of service. The highest threat from this vulnerability is availability. This flaw affects Undertow versions prior to 2.0.35.SP1, prior to 2.2.6.SP1, prior to 2.2.7.SP1, prior to 2.0.36.SP1, prior to 2.2.9.Final and prior to 2.0.39.Final.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.undertow:undertow-core | ≥ 2.1.0&&< 2.2.9.Final | 2.2.9.Finalio.undertow:undertow-core:2.2.9.Final |
| ☕Maven | io.undertow:undertow-core | all versions | 2.0.39.Finalio.undertow:undertow-core:2.0.39.Final |
Affected Products
active iq unified managernetapponcommand insightnetapponcommand workflow automationnetappfuseredhatjboss enterprise application platformredhatopenshift application runtimesredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.undertow:undertow-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.undertow:undertow-core to 2.2.9.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3597 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat OpenStack Platform's OpenDaylight will not be updated for this flaw because it was deprecated as of OpenStack Platform 14 and is only receiving security fixes for Important and Critical flaws.
| Product | Fixed in | Advisory |
|---|---|---|
| EAP 7.3.9 release | undertow | RHSA-2021:3471 |
| Red Hat EAP-XP 2.0.0 via EAP 7.3.x base | undertow | RHSA-2021:3516 |
| Red Hat Fuse 7.10 | undertow | RHSA-2021:5134 |
| Red Hat JBoss Enterprise Application Platform | io.undertow/undertow-core:2.2.9.SP1-redhat-00001 | RHSA-2021:3660 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6 | eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el6eap | RHSA-2021:3466 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7 | eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el7eap | RHSA-2021:3467 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 8 | eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el8eap | RHSA-2021:3468 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-undertow-0:2.2.9-2.SP1_redhat_00001.1.el8eap | RHSA-2021:3658 |
Frequently Asked Questions
Is CVE-2021-3597 in your dependencies?
Find it across Maven, including transitive dependencies.