CVE-2021-3536 — wildfly-parent
MEDIUMCVE-2021-3536 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in org.wildfly:wildfly-parent. A fix is available for org.wildfly:wildfly-parent — see the affected versions and patch details below.
Cross-site Scripting in Wildfly
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.wildfly:wildfly-parentReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Wildfly in versions before 23.0.2.Final while creating a new role in domain mode via the admin console, it is possible to add a payload in the name field, leading to XSS. This affects Confidentiality and Integrity.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.wildfly:wildfly-parent | all versions | 23.0.2.Finalorg.wildfly:wildfly-parent:23.0.2.Final |
Affected Products
build of quarkusredhatdata gridredhatdescision managerredhatintegration camel kredhatintegration camel quarkusredhatintegration service registryredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly:wildfly-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.wildfly:wildfly-parent to 23.0.2.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3536 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw does not affect Red Hat CodeReady Studio 12 because it uses the Wildfly client only. The domain mode is not used.
| Product | Fixed in | Advisory |
|---|---|---|
| EAP 7.3.8 | wildfly | RHSA-2021:2696 |
| Red Hat EAP-XP 2.0.0 via EAP 7.3.x base | wildfly | RHSA-2021:2755 |
| Red Hat Fuse 7.10 | wildfly | RHSA-2021:5134 |
| Red Hat JBoss Enterprise Application Platform | org.jboss.hal/hal-console:3.3.7.Final-redhat-00001 | RHSA-2021:3660 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6 | eap7-elytron-web-0:1.6.3-1.Final_redhat_00001.1.el6eap | RHSA-2021:2692 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7 | eap7-elytron-web-0:1.6.3-1.Final_redhat_00001.1.el7eap | RHSA-2021:2693 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 8 | eap7-elytron-web-0:1.6.3-1.Final_redhat_00001.1.el8eap | RHSA-2021:2694 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-wildfly-0:7.4.1-2.GA_redhat_00003.1.el8eap | RHSA-2021:3658 |
Frequently Asked Questions
Is CVE-2021-3536 in your dependencies?
Find it across Maven, including transitive dependencies.