NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2021-33036 — hadoop-yarn-server-common

HIGHFix: apache/hadoop@227d64a

CVE-2021-33036 is a high-severity (CVSS 8.8) CWE-24 vulnerability in org.apache.hadoop:hadoop-yarn-server-common. A fix is available for org.apache.hadoop:hadoop-yarn-server-common — see the affected versions and patch details below.

User account escalation in Apache Hadoop

Also known asGHSA-58jx-f5rf-qgqf
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
1.45%2.49%3.52%4.55%2.1%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.hadoop:hadoop-yarn-server-common☕org.apache.hadoop:hadoop-yarn-server-common☕org.apache.hadoop:hadoop-yarn-server-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.hadoop:hadoop-yarn-server-common≥ 2.2.0&&< 2.10.22.10.2org.apache.hadoop:hadoop-yarn-server-common:2.10.2
☕Mavenorg.apache.hadoop:hadoop-yarn-server-common≥ 3.0.0&&< 3.2.33.2.3org.apache.hadoop:hadoop-yarn-server-common:3.2.3
☕Mavenorg.apache.hadoop:hadoop-yarn-server-common≥ 3.3.0&&< 3.3.23.3.2org.apache.hadoop:hadoop-yarn-server-common:3.3.2

Affected Products

1 product · 7 configurations
Application
hadoopapache
≥ 3.3.0 && < 3.3.2
1 version
3.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-yarn-server-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.hadoop:hadoop-yarn-server-common to 2.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-33036 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
O3 Security · Impact-Aware SCA

Is CVE-2021-33036 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-33036: hadoop-yarn-server — Fixed in 2.10.2