CVE-2021-32740 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in addressable. A fix is available for addressable — see the affected versions and patch details below.
Regular Expression Denial of Service in Addressable templates
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
addressableReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Within the URI template implementation in Addressable, a maliciously crafted template may result in uncontrolled resource consumption, leading to denial of service when matched against a URI. In typical usage, templates would not normally be read from untrusted user input, but nonetheless, no previous security advisory for Addressable has cautioned against doing this. Users of the parsing capabilities in Addressable but not the URI template capabilities are unaffected.
Patches
The vulnerability was introduced in version 2.3.0 (previously yanked) and has been present in all subsequent versions up to, and including, 2.7.0. It is fixed in version 2.8.0.
Workarounds
The vulnerability can be avoided by only creating Template objects from trusted sources that have been validated not to produce catastrophic backtracking.
References
- https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS
- https://cwe.mitre.org/data/definitions/1333.html
- https://www.regular-expressions.info/catastrophic.html
For more information
If you have any questions or comments about this advisory:
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | addressable | ≥ 2.3.0&&< 2.8.0 | 2.8.0bundle update addressable --conservative |
Affected Products
addressableaddressable_projectfedorafedoraprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for addressable, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update addressable to 2.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-32740 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat CloudForms 5.0 (CFME 5.11) is in the maintenance support phase and we are no longer fixing Moderate/Low severity security bugs. Reference: https://access.redhat.com/support/policy/updates/cloudforms OpenShift 3.11 components are currently in maintenance support phase, hence Moderate/Low severity security bugs…
Create template objects only from trusted sources that have been validated not to produce catastrophic backtracking.Source: Red Hat security advisory for CVE-2021-32740 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| OpenShift Logging 5.2 | openshift-logging/fluentd-rhel8:v5.2.0-10 | RHBA-2021:3393 |
| Red Hat Satellite 6.10 for RHEL 7 | tfm-rubygem-addressable-0:2.8.0-1.el7sat | RHSA-2021:4702 |
Frequently Asked Questions
Is CVE-2021-32740 in your dependencies?
Find it across RubyGems, including transitive dependencies.